Trace: » Технические требования

Технические требования

Используемые технологии

  • Язык PHP;
  • Базы данных MySQL;
  • HTML для веб-страниц;
  • CSS таблицы стилей;
  • CSV, PDF и SLK для экспорта данных;
  • SVG и PNG для изображений и графики.

Веб-сервер

GLPI необходим веб-сервер, который поддерживает PHP. Такой как:

PHP

GLPI требует PHP версии 5 или выше (http://www.php.net). Следующие расширения PHP необходимы для надлежащего функционирования приложения:

  • JSON;
  • MBstring;
  • MySQL;
  • Session.

Следующие расширения PHP не обязательны, но рекомендуется для использования возможностей GLPI:

  • CLI: для работы с командной строкой;
  • CURL: для проверки подлинности CAS;
  • DOMXML: для проверки подлинности CAS;
  • GD: для генерации изображений;
  • IMAP: для работы с почтовыми серверами, используемых для сбора заявок или аутентификации пользователей;
  • LDAP: для использования внешних каталогов для проверки подлинности;
  • OpenSSL: для зашифрованного соединения.

Конфигурация PHP

В файл конфигурации PHP (php.ini) должны быть внесены следующие поправки:

memory_limit = 64M / / Минимальное значение

file_uploads = о;

max_execution_time = 600

register_globals = Off magic_quotes_sybase = OFF;

session.auto_start = OFF;

session.use_trans_sid = 0;

Сервер баз данных

Для работы требуется GLPI сервер баз данных MySQL версии 4.23 или выше (http://www.mysql.com).

Важно: В настоящее время только сервер баз данных MySQL поддерживается GLPI.