Présentation du plugin compte

Ce plugin permet de créer et de recenser les comptes de votre réseau et de relier à vos matériels concernés.

On peut aussi lier des documents et des tickets.

Un email est envoyé selon un délai défini si une date de fin de validité du compte est renseignée.

Pré-Requis

0.71.x Le module PHP mcrypt est nécessaire (package “php4-mcrypt” ou “php5-mcrypt” sous debian 4, suivant votre version de PHP).

0.72 Plus aucun module supplémentaire n'est nécessaire.

Installation

Après la décompression de l'archive dans la dossier plugin de glpi connectez vous sur GLPI en tant qu'administrateur :

Menu : Configuration / Plugins / Comptes / Installation

Cette opération permet de créer les tables utilisées par l'extension.

0.72 : Mise à jour depuis une ancienne version du plugin

<note tip>

Il faut impérativement faire la procédure d'upgrade si vous migrez d'une version du plugin plus ancienne.

</note>

<note important> Première chose très importante : faites une sauvegarde de votre base de données GLPI au préalable </note>

1. Installez le plugin

2. Allez dans la configuration du plugin (cliquez sur le nom du plugin depuis la liste des plugins GLPI)

3. Entrez dans la zone de texte, la nouvelle clé de cryptage que vous voulez utiliser. Exemple 'glpi'. Puis cliquez sur Générer le hash à partir de cette clé de cryptage

4. Ceci ouvre une boite de dialogue. Sélectionnez le hash et copier-coller le en dessous. Puis cliquez sur Générer.

5. Vous êtes alors redirigé vers la page d'upgrade de vos anciens mots de passes. Le plugin vous liste les mots de passes de la base ainsi que le hash créé.

6. Cliquez sur Mettre à jour

7. Vous pouvez commencer à utiliser le plugin et crypter / décrypter vos mots de passes.

<note important> Ne modifiez pas ensuite la clé de cryptage, sinon vos mots de passes seront illisibles et vous devrez recréer vos comptes (Le changement de la clé sera possible dans une version ultérieure). </note>

<note> En cas de problème lors de la mise à jour du plugin et des mots de passes.

1. Restaurez votre base de données GLPI

2. Supprimez la table glpi_plugin_compte_hash (avec phpmyadmin)

3. Fermez votre navigateur

4. Relancez la procédure d'installation et d'upgrade des mots de passe. </note>

Gestion des droits

0.72 :

Menu : Administration / Profils / Onglet Comptes

0.71 :

Menu : Configuration / Plugins / Comptes / Gestion des droits par profil

Cette étape vous permet de définir les profils utilisateurs qui pourront utiliser l'extension.

Problèmes connus

v1.3 line 467 in setup.php

Replace

if ($val==1 && ($data['device_type']!=USER_TYPE)){

with

if ($val==1 && ($data['type']!=USER_TYPE)){