Guide de migration de version GLPI

Le guide complet de mise à jour de GLPI est disponible sur le site de GLPI.

Pré-requis

  • Paramètres PHP : il faut bien vérifier que vous avez alloué assez de mémoire et de temps d'exécution à PHP.
  • Version de PHP et MySQL : bien regarder les pré-requis concernant les version supportées de ces 2 logiciels
  • Paquets : pensez à bien vérifier (si vous changez de machine en migrant) que vous aviez bien réinstallé tous les paquets nécessaires :
    • php-ldap : pour la connexion à l'annuaire
    • php-imap : pour la partie passerelle mail

<note warning> A partir de GLPI 0.72, PHP4 n'est plus supporté par GLPI. Veuillez noter, de plus, que certains plugins compatibles GLPI 0.71 ne supportent déjà pas cette version de PHP. </note>

<note warning> Pensez bien, lors de la migration, à enlever les plugins de votre répertoire GLPI. Vous pourrez les mettre à jour par la suite, une fois GLPI fonctionnel </note>

Messages d'erreurs potentiels

Si, lors de la migration, vous rencontrez une page blanche, pas de panique :

  • Passez en mode debug
  • Vérifiez les droits sur les fichiers :
    • config et files/ en lecture/écriture pour tout le monde
    • files/ appartient bien à l'utilisateur d'apache

<note> Si les messages persistent, vous pouvez expliquer le comportement observé sur le forum. Pour cela, il faut bien respecter les règles avant de poster </note>